完美解决:You are using pip version 19.0.3, however version 20.0.2 is available.......问题

安装python第三方库的时候总是安装不上。提示说让You should consider upgrading via the 'python -m pip install --upgrade pip' command.输入python -m pip install --upgrade pip命令升级pip版本。但是输入之后仍然不可以。

输入升级命令之后提示已经是最新的pip,但是再使用pip install scipy或者pip3 install scipy(我的电脑上有两个pip。分别是pip、pip3)命令还是报相同的错误。

最后输入:pip3 install --index-url https://pypi.douban.com/simple scipy命令终于安装成功了。

出现这种情况实际是因为国外的网站访问限速,所以会一直报错timeout,可以用参数延长timeout也可以换源。如果你也遇到同样的情况,可以试一试用这个命令来安装所需要的第三方库:pip3 install --index-url https://pypi.douban.com/simple xxxx。或者使用pip install -i https://pypi.tuna.tsinghua.edu.cn/simple xxxx 从清华镜像获取库。

常见pip下载镜像还有:

阿里:https://mirrors.aliyun.com/pypi/simple

中国科学技术大学:https://pypi.mirrors.ustc.edu.cn/simple

 

 

 

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: Age of Ai 设计师:meimeiellie 返回首页